meta data for this page
  •  

MAC OSX

Paul Beach

Installation on MacOSX is extremely simple:

  • As SU, download the compressed pkg kit to a convenient location and decompress it.
  • Click on the pkg file to kick off the installation.
  • Follow the instructions (choose disk, enter SU password) and you are done.

Uninstalling on MacOSX

MacOSX has no uninstall utility but the following script will clean up Firebird installs on Leopard. It should work on Tiger as well.

#!/bin/sh
echo "Clean Services"
echo "Clean User"
dscl localhost -delete /Local/Default/Users/firebird
echo "Clean Group"
dscl localhost -delete /Local/Default/Groups/firebird
if [ -f "/Library/StartupItems/Firebird" ]; then
echo "Remove SuperServer StartupItem"
rm -fr /Library/StartupItems/Firebird
fi
if [ -f "/Library/LaunchDaemons/org.firebird.gds.plist" ]; then
echo "Remove Launchd"
launchctl unload /Library/LaunchDaemons/org.firebird.gds.plist
rm /Library/LaunchDaemons/org.firebird.gds.plist
fi
echo "Remove Framework"
rm -fr /Library/Frameworks/Firebird.framework
echo "Remove Receipt"
rm -fr /Library/Receipts/Firebird*.pkg